Unstable Terra Network
Incident Report for Finblox
Resolved
This incident has been resolved.
Posted May 27, 2022 - 23:43 UTC
Update
We are continuing to monitor for any further issues.
Posted May 23, 2022 - 11:43 UTC
Update
We are continuing to monitor for any further issues.
Posted May 23, 2022 - 08:32 UTC
Update
We are continuing to monitor for any further issues.
Posted May 23, 2022 - 08:18 UTC
Monitoring
The Terra blockchain is experiencing degraded network performance. LUNA and UST withdrawals are currently disabled.
Posted May 23, 2022 - 02:10 UTC
This incident affected: Transfers.