Delays in outgoing transactions

Incident Report for Finblox

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jun 16, 2023 - 08:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 16, 2023 - 04:15 UTC

Investigating

We are currently encountering issues that may cause delays in outgoing transfers. We appreciate your patience.
Posted Jun 16, 2023 - 02:57 UTC
This incident affected: Transfers.