Intermittent delay with transaction processing
Incident Report for Finblox
Resolved
This incident has been resolved. Thank you for your patience.
Posted May 12, 2023 - 13:18 UTC
Identified
Our custodian partner, Fireblocks, is experiencing intermittent delays with transaction processing. Please expect deposits and withdrawals to be delayed.

For more information: https://status.fireblocks.com/incidents/py6kt4ywrbk4
Posted May 12, 2023 - 11:10 UTC
This incident affected: Transfers.