Issues with creating addresses and delays on transfers
Incident Report for Finblox
Resolved
This incident has been resolved.
Posted May 23, 2022 - 22:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2022 - 11:43 UTC
Identified
Our provider is running an unexpected update on their infrastructure.
Posted May 23, 2022 - 08:20 UTC
This incident affected: Mobile Application and Transfers.