Intermittent delays with incoming and outgoing transactions
Incident Report for Finblox
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 16:39 UTC
Identified
We are currently experiencing delays in transfers. Our partner, Fireblocks, is continuing to work on a fix for this issue.

More details: https://status.fireblocks.com/incidents/n1vzn0knty9n
Posted Dec 18, 2023 - 16:13 UTC
This incident affected: Transfers.